Kontur um ein Bild

  • Version 8.5x
  • Kontur um ein Bild

    Guten Abend, habe ein Bild, welches skaliert wird mit einer Kontur im Layouter versehen. Beim Abspielen flackert die Kontur, was störend wirkt. Die Kontur ist Händisch mit dem Curser ist bei einem Bild die Kontur in Ordnung, beim nächsten Bild nicht. Die Kontur ist mit 1,5px festgelegt, auch beim Wechsel von "Beide", "innen" und "außen" ist kein Unterschied.
    Gruß Käferl
  • Hi Käferl

    käferl schrieb:

    Die Kontur ist Händisch mit dem Curser ist bei einem Bild die Kontur in Ordnung, beim nächsten Bild nicht
    was genau bedeutet das?

    Kannst du bitte mal mitteilen, welche Projekteinstellungen (Framerate und p oder i) du eingestellt hast, und in welchem Format dein Videomaterial vorliegt? Ich hab zwar jetzt noch keine Ahnung, woran das Flackern liegen könnte, aber diese Einstellungen wären mal ein Ansatz.

    Gruß Uwe
    Edius Pro 8.53 / PC Win7 Home Premium SP1, Intel i5, 3,2GHz, 8GB RAM, 256 GB SSD für System, 1 TB HDD für Daten, Lieblingsspielzeug: ShuttlePRO v2
  • Guten Abend Uwe,
    im Dateianhang meine Projekteinstellung. Mit dem Curser meine ich Bild für Bild weitergehen.
    Das Bild selbst ist von einem Photo gescannt und im Layouter bearbeitet. Nun habe ich es mir nochmals angesehen, dieses flackern ist nur wenn das Bild beim Skalieren größer oder kleiner wird, bei Ruhestellung ist es in Ordnung.
    Gruß Käferl
    Bilder
    • Projekteinstellung.jpg

      130,16 kB, 765×382, 53 mal angesehen
  • Servus Käferl,

    das Problem liegt höchstwahrscheinlich in der sehr dünnen Linie von 1,5px. Probier mal mit 2, 3 oder 4 herum und ich bin mir sicher, das Flimmern ist weg. Vielleicht hilft ja auch noch der Antiflicker Effekt!

    LG Markus
    EDIUS 8.53 Pro; Asus Z170-A; i7 6700K; Noctua NH-D14; G.Skill RipJaws 32GB DDR4-2133; Samsung SSD 850 Evo 250GB M.2; MSI GTX 960 4GD5T OC GeForce GTX 960 4GB; 3x HGST Deskstar NAS 3TB SATA; Exsys EX-6450; Fractal Design Define R5; Win7 Professional
  • Wenn ich dich richtig verstanden habe, ändert das Bild während dem Film die Größe und dabei flackert der Rahmen.

    Ich hab mal ein par Tests gemacht.
    Projekte in 50i, 25p, 50p angelegt, jeweils ein Bild auf die Timeline. skalierung animiert, Rahmen drum gemacht.
    Bei allen Projekten die Einstellung: Benutzereinstellung - Vorschau - Overlay - Aktualisierungsfrequenz - Halabbild und Bild ausprobiert.
    Alle Filme exportiert und angeschaut.


    Ergebnis: Bei allen Varianten flackert der Rahmen im Projekt und im berechneten Film.

    Also nachvollziehen kann ich das Problem. Lösung habe ich bis jetzt noch keine. Ich denke mal weiter drüber nach. Wahrscheinlich hat das was mit Bildraten und progresiv oder interlace zu tun. Vielleicht auch mit den 60 Herz, die mein Bildschirm anzeigt. Ich teste weiter.
    Gruß Uwe
    Edius Pro 8.53 / PC Win7 Home Premium SP1, Intel i5, 3,2GHz, 8GB RAM, 256 GB SSD für System, 1 TB HDD für Daten, Lieblingsspielzeug: ShuttlePRO v2
  • So. Problem gefunden.
    In einem Projekt mit 60p flackert nichts - weil das der Aktualisierungsfrequenz meines Bildschirms entspricht - 60 Herz.

    @ Markus: Dickere Linien flackern leider auch.

    @ Käferl: Probiere mal, dieinen Vorschaubildschirm auf 50 Herz einszutellen.

    Gruß Uwe
    Edius Pro 8.53 / PC Win7 Home Premium SP1, Intel i5, 3,2GHz, 8GB RAM, 256 GB SSD für System, 1 TB HDD für Daten, Lieblingsspielzeug: ShuttlePRO v2
  • käferl schrieb:

    Das Bild selbst ist von einem Photo gescannt ... ...dieses flackern ist nur wenn das Bild beim Skalieren größer oder kleiner wird, bei Ruhestellung ist es in Ordnung.

    Hi,

    ich verstehe es jetzt so, dass nur die "Kontur" flackert und nicht das eigentliche (vollständige) Bild.

    Das liegt daran, dass es sich um ein SD - Projekt handelt, also mit Halbbildern.
    Dadurch entsteht beim Skalieren der (Kamm-)Effekt. Wenn Du die Kontur im Layouter wegnimmst, wirst Du erkennen, dass dieses "Flimmern" jetzt auf dem direkten Rand des Bildes eintritt.

    Ganz wegbekommen wirst es nicht. Du kannst aber versuchen es etwas zu reduzieren, indem Du im Layouter in der Einstellung für
    1. "Stretch" (Skalierung) eine andere Resampling-Methode wählst,
      - hier könnte Lanczos 2 oder Lanczos 3 Glatter vermutlich ein etwas gefälligeres Ergebnis erbringen, musst Du aber ausprobieren;
    2. "Kontur" bei "Weich" (Haken setzen nicht vergessen) einen Wert eingibst,
      - dadurch wird der "Rahmen" zwar breiter, aber das "Flacken" reduziert,
      - ich denke, der Wert für "Weich" sollte über 5 (px) liegen, aber das musst Du nach Deinem Geschmack und Vorstellungen bewerten.


    Diese beiden Maßnahmen zusammen sollte das Flackern dann doch deutlich verringern.

    Die von die angesprochen Einstellungen - "Beide", "innen" und "außen" - beziehen sich auf die Gestaltung der Ecken der Kontur und wird nur wirksam, wenn das Kästchen davor angehakt ist.
    Evtl. könnte hier "Beide" (also die Ecken innen und außen gerundet) auch etwas besser aussehen. Aber auch dass musst Du ausprobieren.



    Gruß
    Peter
    ASUS P9X79 - i7-4820K CPU 3,70 GHz - 32 GB RAM - PNY Quadro K2000D - 256 GB Samsung SSD + 2 x 2 TB als RAID 1 - RME Fireface 400 - Win 10 Pro - EDIUS WG 9 - BMD FUSION 9
  • Hi Peter,

    in meinen Projekten - also auch in den oben genannten Tests - ist Lanczos 3 immer Standard. Das flackert trotzdem.
    Aber dein Vorschlag weiche Kante funktioniert sehr gut. Ich hab die Kontur auf 3 px und die weiche Kante auf 2 px gestellt,weil Käferl ja einen sehr dünnen Rand will. Die Kontur sieht jetzt gut aus. Das Ränder vom Bild flackern jetzt ganz leicht. Aber das stört bei der sowieso schon schlechten Qualität von SD nicht weiter.

    Gruß Uwe
    Edius Pro 8.53 / PC Win7 Home Premium SP1, Intel i5, 3,2GHz, 8GB RAM, 256 GB SSD für System, 1 TB HDD für Daten, Lieblingsspielzeug: ShuttlePRO v2
  • Guten Abend,
    ich habe nun die Kontur auf 2px und "weiche Kontur" auf 4px gestellt, es ist zwar besser, aber es gefällt mir nicht so gut, nun lasse ich es wie es war. Es ist auch nicht unbedingt notwendig, ich dachte mehr an eine falsche Einstellung. Danke an alle für die guten Ratschläge!
    Gruß Käferl
  • Uwe8 schrieb:

    in meinen Projekten - also auch in den oben genannten Tests - ist Lanczos 3 immer Standard. Das flackert trotzdem.
    Was da vorgegeben ist, richtet sich jeweils nach den in Edius gemachten Einstellungen (Projekt, Layouter, usw.).

    Bei Lanczos 3 gibt es dann noch (3) verschiedene "Unterarten".
    Lanczos 3 Glatter ist ausgewiesen für Grafiken, Lanczos 3 Schärfer für Progressiv. Das sind aber auch nur "Richtwerte" und man sollte - im Bedarfsfall - prüfen was evtl. das für einen optimale Ergebnis bringt.


    Wie schon gesagt liegt das Hauptproblem im hier angesprochenen Fall in der für heutige Verhältnisse geringen Auflösung und den Halbbildern von SD-Projekten.
    Da waren dünne Kanten, ungünstige Schriften usw. schon immer ein Problem, insbes. bei Bewegungen (hier die Skalierung). Nur ist man heute eben "besseres" gewohnt und dadurch fällt es dann auf.

    Gruß
    Peter
    ASUS P9X79 - i7-4820K CPU 3,70 GHz - 32 GB RAM - PNY Quadro K2000D - 256 GB Samsung SSD + 2 x 2 TB als RAID 1 - RME Fireface 400 - Win 10 Pro - EDIUS WG 9 - BMD FUSION 9
  • Flackern kann es auch mal in zu feinen Strukturen des Progressivvideo, wie Busch- oder Astzweigen im Falle von Kameras
    die mit einer künstlichen Kantenaufsteilung arbeiten um die so heiß ersehnte Super-Schärfe vieler Kunden zu befrieden.
    Ein solches Material hatte ich oft schon hier vorliegen, man muss dann die Überschärfung herabsetzen z.B. mit dem
    Matrix-Filter und evtl, noch zusätzlich mit Anti-Flimmer filtern. Im Falle von Skalierungen dann nicht Lanczos3 wählen,
    sondern z.B. "Bilinear(Schnell und glatt)".
    Servus, Pee
    EDIUS Pro 9.xx(H.264/H.265-8bit), i7-6700-PC mit Intel HD-530(QS-Konfiguration), 16Gb RAM, SSD-System + Diverse FP, NVIDIA GF-GTX 960, W10-V1803, 27" Desktop-Monitor HDMI/DVI, 24" HDTV per VGA
  • Ich hab mal alle Resamplingmethoden ausprobiert. Alle mit und ohne weicher Kante.
    Die weiche Kante ist wohl die wichtigste Einstellung um das Flackern zu vermeiden. Ohne die flackert alles mehr oder weniger.
    Von den Resamplingmethoden passt Lanczos 3 glatter am besten. In Kombination mit weicher Kante sind die Ergebnisse wirklich gut. Der Rand bleibt ruhig. Nur das Bild flackert am Rand noch ein wenig.
    Interessant wäre es mal, wenn jemand ein Test mit einem 50i Projekt auf einem Monitor mit 50 Herz machen könnte. Ich glaube, die Darstellungsart am Monitor ist auch ein Grund für das Flackern. Mein Monitor hat 60 Herz. Bei einem 60p Projekt Flackert da überhaupt nichts. Egal welche Resamplingmethode ich wähle.
    Edius Pro 8.53 / PC Win7 Home Premium SP1, Intel i5, 3,2GHz, 8GB RAM, 256 GB SSD für System, 1 TB HDD für Daten, Lieblingsspielzeug: ShuttlePRO v2
  • raptor9 schrieb:

    Stimmt deine Halbbildreihenfolge mit dem Original überein?
    Laut @käferl ist das betroffene Ausgangsmaterial ein Standbild.
    Da das Bild selbst nicht flackert, sind in Edius offenbar die richtigen Parameter unter Einstellungen > Systemeinstellungen > Import/Export > Standbild ausgewählt.

    Sonst hättest Du aber durchaus recht, dass dies eine Fehlerquelle sein kann.
    ASUS P9X79 - i7-4820K CPU 3,70 GHz - 32 GB RAM - PNY Quadro K2000D - 256 GB Samsung SSD + 2 x 2 TB als RAID 1 - RME Fireface 400 - Win 10 Pro - EDIUS WG 9 - BMD FUSION 9
  • Hallo,
    da du schreibst, dass das Problem bei einem Bild auftritt, bei einem andren nicht, kann folgendes helfen: füge das Bild ohne Rand in ein Programm wie Adobe Photoshop Elements ein. Dort bei Filtern Videofilter auswählen und deinterlace durchführen. Danach das Bild wieder in Edius einfügen.
    Ein wackelndes Standbild wird erzeugt, wenn man bei der Erstellung des Standbildes genau den Bildwechsel erwischt.
    Der Fehler sollte nur nach dem Exportieren sichtbar sein - auf der Timeline wird das Bild normalerweise korrekt wiedergegeben.
    Mit freundlichen Video Filmer Grüßen